UTF-8-Kodierung in WLAN-Passwörtern und -Namen (Emoji)

    2012 wurde es möglich, UTF-8-Zeichen im Namen eines WLAN-Netzwerks zu verwenden. Das erste, was mir einfällt, ist, sich von der grauen Masse abzuheben und Emoji-Emoticons im Netzwerknamen zu verwenden. Außerdem können Sie ein Emoji-Kennwort festlegen. Dann können Sie Ihren Freunden sicher sagen: „Verbinden Sie sich mit dem Wi-Fi-Netzwerk, um Käse kostenlos zu erhalten. Das Kennwort lautet: ein Bierkrug und ein Cookie“.


    Nicht alle und nicht sofort begannen diesen Standard zu unterstützen. Es sind jedoch 7 Jahre vergangen, und der Boom der Emoticons bei den Namen von Heimroutern ist nicht geschehen. Also lasst uns diesen Boom jetzt arrangieren!
    Es ist schade, dass nicht alle Firmwares dies erlauben. Zum Beispiel kann ZyXel Keenetic 4G II mit der neuesten Beta-Firmware von 2017 nicht wissen, wie UTF-8 als SSID verwendet wird. Vielleicht kann man es irgendwie über die CLI konfigurieren, aber es ist mir nicht gelungen. In neuen Versionen der ZyXel-Firmware wurde diese Funktion hinzugefügt, es wird jedoch mehr neue Hardware benötigt. Es sei ein weiterer Grund, den Router zu aktualisieren. Auf ASUS, TP-Link und anderem Zoo hat es nicht ausprobiert, ich habe sofort MikroTik genommen, weil Es funktioniert definitiv dort.

    MikroTik


    Ich habe meine Experimente mit der neuesten, stabilen Firmware für heute auf MicroTik hAP lite durchgeführt. Höchstwahrscheinlich funktioniert dieser Trick bei allen Microtics mit jeder Firmware.

    SSID UTF-8


    Es ist ziemlich einfach, den Namen zu ändern, zur Website zu gehen , beliebige Zeichen aus der Platte in die Form zu kopieren, auf Start zu klicken und das Ergebnis in das Terminal zu kopieren:

    /interface wireless set [find name="wlan1"] ssid="\F0\9F\86\93\F0\9F\A7\80"

    Auf dem iPhone sieht es so aus:

    UTF-8-Passwort


    Wenn Gäste verteilt sind, muss das WLAN-Netzwerk geschützt werden. Das Passwort ist ebenfalls eine UTF-8-Zeichenfolge. Wählen Sie auf der gleichen Site ein passendes Kennwort aus und klicken Sie auf Start. Aus dem Ergebnis nehmen wir nur den Wert in Anführungszeichen und schreiben an das Terminal:

    /interface wireless security-profiles set [find name="default"] 
    mode=dynamic-keys authentication-types=wpa2-psk wpa2-pre-shared-key="\F0\9F\86\93\F0\9F\A7\80"

    Verbindung mit Passwort UTF-8


    Und jetzt am schwierigsten. Wie gebe ich das UTF-8-Passwort ein? Wenn Sie Text in Messenger eingeben, gibt es ein spezielles Tastaturlayout mit Emoji-Symbolen. Bei der Eingabe eines WLAN-Passworts steht jedoch nur die Standardtastatur zur Verfügung! Sie können annehmen, dass Sie den Text der Nachricht aus dem Messenger kopieren und anstelle des Kennworts einfügen. Dies funktioniert jedoch wahrscheinlich nicht. Sie können dieses Rätsel auf Ihre bekannten Sysadmins setzen.

    Der Benutzer ky0 hat die Verwendung eines QR-Codes mit Verbindungsdetails vorgeschlagen . Dieser Trick funktionierte jedoch nicht auf meinem iPhone.

    Verbinden Sie Mac, iPhone, iPad


    So habe ich diese Einschränkung auf Apple-Geräten umgangen: Ich habe den Mac über die Konsole verbunden, und der Rest von iDevices hat das WLAN-Netzwerkprofil aus der Cloud heruntergeladen!

    Scannen Sie das Wi-Fi-Netzwerk mit dem Befehl:

    /System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/airport -s

    Und lassen Sie uns mit einem bestimmten Passwort eine Verbindung zu unserem Netzwerk herstellen (das Terminal kann im Gegensatz zu Habr UTF-8 verwenden):

    networksetup -setairportnetwork en1 [название] [пароль]

    Meine Netzwerkkarte befindet sich auf en1. Sie können sich unterscheiden. Überprüfen Sie mit dem Befehl:

    networksetup -listallhardwareports



    Jetzt hat der Mac erfolgreich eine Verbindung mit dem Netzwerk hergestellt. Nach kurzer Zeit synchronisiert er die Passwörter mit der iCloud, und das iPhone lädt sie in Kürze herunter und stellt selbst eine Verbindung zu unserem WLAN her.

    PS: Im Kampfsystem sollten solche Passwörter nicht genau festgelegt werden. Obwohl der Name des Netzwerks ihnen keinen Schaden zufügt, auch wenn kein Smiley angezeigt wird, kann das Gerät eine Verbindung zum Netzwerk herstellen. Ein UTF-8-Passwort in einem Café oder Büro einzutragen, folgt jedoch nicht - Besucher und Kollegen werden den Humor nicht zu schätzen wissen.

    Zu Hause - warum nicht? Wenn alle Geräte normalerweise ein solches Passwort akzeptieren, ist es unwahrscheinlich, dass der Nachbar von Vaska eine Verbindung zu einem solchen Netzwerk herstellen kann. Ein Plus wäre der Schutz vor roher Gewalt und das Abfließen von Passwörtern in die Datenbanken von 3wifi.stascorp.com.. Die gängigen Cracker-Router von RouterScan verwenden die ASCII-Kodierung. Wenn Sie also ein Smiley in ASCII konvertieren, gibt es entweder einen Quack-Cracker oder eine leere Zeichenfolge. Übrigens, überprüfen Sie Ihren Router, vielleicht war er schon lange in der 3Wifi-Datenbank ... Das Coole

    ist das UTF-8-Passwort! Lächeln ist leicht zu merken, Sie können verschiedene Sprachen verwenden, nicht nur Englisch + Zahlen + einige Sonderzeichen. Fehlt nur native Unterstützung in Gadgets. Hoffentlich werden Hersteller UTF-8 mit WPA3 unterstützen .

    ZyXel Keenetic


    ZyXel Keenetic OS unterstützt in UTF-8 codierte SSID in Firmware 2.13.С0 ab 09/09/2018
    Geräteliste
    Keenetic Giga (KN-1010)
    Keenetic Start (KN-1110)
    Keenetic 4G (KN-1210)
    Keenetic Lite (KN-1310)
    Keenetic Omni (KN-1410)
    Keenetic City (KN-1510)
    Keenetic Air (KN-1610)
    Keenetic Extra (KN-1710)
    Keenetic Ultra (KN-1810)
    Zyxel Keenetic Start II
    Zyxel Keenetic Lite III rev.B
    Zyxel Keenetic 4G III rev.B
    Zyxel Keenetic Giga III
    Zyxel Keenetic Ultra II
    Zyxel Keenetic Air
    Zyxel Keenetic Extra II

    Bei unterstützten Geräten ändert sich die SSID über die Webschnittstelle.

    Xiaomi


    Die auf Lager erhältliche Firmware unterstützt UTF-8.
    Kommentare von Extrawelt

    Router mit Padavan-Firmware


    Der Xiaomi-Router mit der Padavan-Firmware erlaubt es nicht, Emojis standardmäßig als SSID festzulegen. Aber seit Die Validierung erfolgt in JS. Sie wird ganz einfach über die Entwicklerkonsole gelöst, beispielsweise in Chrome.

    Sie müssen nur auf der SSID-Bearbeitungsseite auf die Konsole schreiben:
    window.validate_ssidchar = function () { return true; };


    Damit Emoji in das Passwort eingegeben werden kann, müssen Sie eine andere Validierungsfunktion deaktivieren:
    window.validate_string = function () { return true; };

    Quelle: www.reddit.com/r/javascript/comments/5zcb8m/can_you_help_me_allow_my_router_to_accept_as_the
    Vielen Dank an ferosod für diesen Kommentar !

    Android


    Mit Samsung Galaxy S8 + (Android Pie) können Sie einen kopierten Emoji aus dem Puffer in den Netzwerknamen und das Kennwort einfügen. Tastaturstandard von Samsung. ( infa von DaemonGloom ).

    UPD: Vielen Dank an alle für das Feedback, ich aktualisiere das Thema mit Ihren Beobachtungen. Ich frage mich, ob Sie es geschafft haben, sich mit QR-Code zu verbinden ? Und sie interessieren sich für Asus, Tp-Link und D-Link Router.

    TODO:

    • UTF-8 SSID-Unterstützung in ASUS / TP-Link / D-Link / etc-Routern?
    • Verbindung mit Passwort UTF-8 unter Windows / Linux / Android?
    • Versuchen Sie den QR-Code , um eine Verbindung herzustellen
    • Skriptanimation

    Nur registrierte Benutzer können an der Umfrage teilnehmen. Bitte melden Sie sich an.

    Verwenden Sie UTF-8 in Wi-Fi?


    Jetzt auch beliebt: